4. Die bedingte Anweisung

Aus dem Alltag kennst du Situationen, in denen du Abhängig von Bedingungen eine Entscheidung triffst und entweder das Eine oder das Andere tust. Zum Beispiel wirst du, wenn du aus dem Haus gehst, bei drohendem Regen zu einer Regenjacke greifen und andernfalls vielleicht eine gewöhnliche Stoffjacke anziehen.
Auch bei Karol gibt es diese Situation. Mann nennt sie Auswahl oder bedingte Anweisung.

Struktogramm Programm
wenn Bedingung dann
   Sequenz1
sonst
   Sequenz2
*wenn

Oft muss nur entschieden werden, ob eine Sequenz ausgeführt wird oder nicht. In diesem Fall vereinfacht sich das Struktogramm. Im Programm kann sonst-Teil einfach weggelassen werden.

Struktogramm Programm
wenn Bedingung dann
   Sequenz1
*wenn

Beispiel

Karol soll in der Reihe seiner Blickrichtung alle Steine entfernen und umgekehrt dort, wo keine Steine lagen, jeweils einen hinlegen.

vorher nacher
Struktogramm Programm
wiederhole solange NichtIstWand
  wenn IstZiegel dann
    Aufheben
  sonst
    Hinlegen
  *wenn
  Schritt
*wiederhole

Aufgabe 1: Steine nach Plan

Karol soll Ziegel nach einem vorgegbenen Plan legen. Überall in der Reihe, wo sich eine Markierung befindet, muss oberhalb ein Stein platziert werden.

vorher nachher
Tipp: Erstelle zunächst eine Welt mit Markierungen und speichere sie ab. Erstelle dann dein Programm. Bei jedem neuen Starten des Programms befindet sich dann in der Welt, wie du sie gespeichert hast.

Aufgabe 2: Auf der Mauer

Karol befindet sich auf einer Mauer, die einen Stein breit ist, aber auch über Ecken verfügen kann. Er soll auf der Mauer bis zur Markierung am Ende der Mauer laufen.

vorher nachher

Dein Programm soll für jede Mauer dieser Art funktionieren.
Benötigst du eine Tipp? Hier findes du einen ersten

Hinweis

Hinweis

Sorge dafür, dass Karol bis zum Ende der geradlinigen Ziegelreihe läuft und lass ihn überprüfen, ob der Weg links oder rechts von ihm weitergeht. Das Vorgehen wiederholt sich solange bis er auf der Marke steht.


Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information
Drucken/exportieren